Voting

Category

real language

Bookmarking

Del.icio.us Digg Diigo DZone Earthlink Google Kick.ie
Windows Live LookLater Ma.gnolia Reddit Rojo StumbleUpon Technorati

Language Wlangage

(Language from PCSoft's Windev)

Date:04/22/11
Author:rompetit
URL:n/a
Comments:0
Info:http://www.windev.com/
Score: (1.67 in 6 votes)
eNbBouteillesAuDébut est un entier = 99
c est un entier
sParolesChanson est une chaine
sDebutLigne2 est une chaine
sNbBouteillesEnCours, sNbBouteillesRestantes sont des chaines
sPluriel1, sPluriel2 sont des chaines

POUR c = eNbBouteillesAuDébut A 0 PAS -1
	sPluriel1 = "s"
	sPluriel2 = "s"
	sNbBouteillesSurLeMur = NumeriqueVersChaine(c)
	sNbBouteillesRestantes = NumeriqueVersChaine(c-1)
	sDebutLigne2 = "Take one down and pass it around"
	SELON c
		CAS 0
			sNbBouteillesSurLeMur = "No more"
			sNbBouteillesRestantes = NumeriqueVersChaine(eNbBouteillesAuDébut)
			sDebutLigne2 = "Go to the store and buy some more"
		CAS 1
			sPluriel1 = ""
			sNbBouteillesRestantes = "no more"
		AUTRES CAS
			SI c=2 ALORS sPluriel2 = ""
	FIN
	sParolesChanson+=sNbBouteillesSurLeMur + " bottle" + sPluriel1 + ...
			" of beer on the wall, " + ...
			Minuscule(sNbBouteillesSurLeMur) + " bottle" + sPluriel1 + ...
			" of beer." + RC + ...
			sDebutLigne2 + ", " + ...
			sNbBouteillesRestantes + "bottle" + sPluriel2 + ...
			" of beer on the wall." + RC
	SI c>0 ALORS sParolesChanson+= RC
FIN
Trace(sParolesChanson)

Download Source | Write Comment

Alternative Versions

Comments

Download Source | Write Comment

Add Comment

Please provide a value for the fields Name, Comment and Security Code.
This is a gravatar-friendly website.
E-mail addresses will never be shown.
Enter your e-mail address to use your gravatar.

Please don't post large portions of code here! Use the form to submit new examples or updates instead!

Name:

eMail:

URL:

Security Code:
  
Comment: